Database Disruption

Incident Report for Titan

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 23:14 EDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 23:14 EDT

Investigating

Following an Amazon AWS outage, a service that support our database, MongoDB, Titan may have issues loading, saving, or editing data. The bot will remain online, but may experience issues in this area.
Posted Oct 20, 2025 - 08:40 EDT
This incident affects: Database Queries.